Atag oven ZX6011KUU/A02

Onze Atag oven bakte fantastisch maar nu is er iets mis:

Het ging fout tijdens het bakken op 210 graden met het compleet uit zichzelf uit- en inschakelen van de oven: je moest dan zelf de temperatuur weer goed zetten (staat standaard op 225 graden).

Vervolgens heb ik de oven van de spanning afgehaald en weer aangesloten, tijd instellen dan deed hij het weer even goed, maar niet altijd.

Nu krijgen wij de foutmelding: "HIJ6 903" en kunnen we er niets meer mee.

Op de site van Atag zijn is deze foutcode helaas niet te vinden:
https://support.atag.nl/support/solutions/folders/77000305357

Is er iemand die kan helpen en wellicht weet wat er aan scheelt?

Alvast bedankt!

Wat is uit zichzelf uit en inschakelen? Complete display dood? Gewoon even verward en zelf gestopt? Welk tijdsbestek. Uit en onmiddelijk terug in? Een uur tussen? Is de toevoer netspanning stabiel? Draait de koelventilator? Hoe ziet de over er binnen uit. Vuile print? Bolle elco's?...

Het uit- en inschakelen gaat heel snel (<1 sec) tijdens het lopende programma. Wel werd daardoor de temperatuur weer naar de standaard waarde gezet (225 graden). Het lijkt meer op een gedeeltelijke reset.

De printen zien er prima uit, schoon en geen stof. geen bolle elco's.

Deze oven wordt tijdens de normale werking goed gekoeld: ook bij het bakproces zonder "hete lucht circulatie" gaat de koelventilator vaak aan en uit dus leek het er eerst op dat hij gewoon door ging.

Wat ik wel een voor heb bij dit soort is een slecht contact in de keuzeschakelaar/encoder/potmeter. Hoe werkt de registratie vd bedieningsknoppen van keuze en temperatuur? Kun je hier mss foto's vanmaken?

Keuzeschakelaar

Hoofdprint met voeding

Temperatuurschakelaar (temp op/neer:links-rechts)

Displayprint

Deurschakelaar

Deze dus. Al menig probleem mee gehad. Welke functie heeft die hier? Draait die 360 graden of maar 270 graden rond?

Ik vermoed in dit geval eerder slechte kontakten op de print. Mss tijdens de werking overal met de achterkant van een goed geïsoleerde schroevendraaier eens tegen tikken (niet stuk slaan) om een reactie uit te lokken.

Edit: wat gebeurt er als je tijdens een bakproces licht aan de keuze- of temperatuurknop komt? Valt hij dan ook zo uit?

[Bericht gewijzigd door EricN op 10 januari 2021 18:10:10 (22%)]

Het lijkt mij niet de temperatuurschakelaar:
Die geef je een 'digitaal' tikje van 30 graden naar links of naar rechts. meer niet en dat werkt normaal.

Het bakproces kan niet meer gestart worden omdat de foutmelding direct verschijnt.

Dan is het een encoder. Die hebben andere problemen die op een andere manier zichtbaar zijn. Stappen weigeren of overslaan. Draait toch 360 gr rond dan?

[Bericht gewijzigd door EricN op 10 januari 2021 18:45:53 (11%)]

Die kan niet ronddraaien.
In de uitstand kan hij 2 x tegen de klok in en 7 x met de klok mee.
Om de kontakten goed te bekijken moet ik hem gaan demonteren, ze zitten aan de onderkant.

Toch nog een kanshebber dan die encoder. Heel fragiel werkje!!! Ik zou eerder de print eerst nakijken. bekijk de laatste foto eens , een goed vb van een los kontakt https://www.circuitsonline.net/forum/reply/152681/2230232
Onderkant bekijken op slechte kontakten. Iets dat je aankan?

Draai die keuzeknop eens een tiental (of meer ) keer uiterst links naar uiterst rechts. Wat gymnastiek ter test of daar iets scheelt. Niet betrouwbare test maar qua huis keuken en tuin is dat verantwoordbaar. tiktest is ook zo eentje.

Ik zie nu dat je het totaal niet over de schakelaar/draaiknop van mijn foto hebt maar over de ovenschakelaar. Dat brengt verwarring in de communicatie!

Encoder kontakten zien er goed uit.

Ook de onderkant van de hoofdprint lijkt prima.

Op 10 januari 2021 19:08:14 schreef EricN:
Ik zie nu dat je het totaal niet over de schakelaar/draaiknop van mijn foto hebt maar over de ovenschakelaar. Dat brengt verwarring in de communicatie!

Sorry, ik weet nu niet wat jij bedoelt.

N.B. Ik ben een wel gepensioneerde maar wel ervaren elektronicus :)

[Bericht gewijzigd door Brechtje op 10 januari 2021 19:16:32 (11%)]

Ik stuur je de foto van de encoder door en je antwoord met de eigenschappen van de keuzeschakelaar.

Enfin, terug op het spoor

Ik heb je foto bewerkt. Kun je de rode cirkels extra aandacht geven. De foto is niet scherp genoeg.

De blauwe kader, kun je kijken waar die draden naartoe gaan?

Het zou kunnen dat de keuzeschakelaar geen stroom draagt maar slecht ter encoding dient in de print zodat er zich op de kontakten oxidatie of vuil kan vestigen.

Krijg je de error ook op stand nul vd keuzeschakelaar? Ook na een hard reset?
Edit: ai, foto vergeten. Hier is hij:

Op geel en groen vd display zou je 5v moeten hebben, klopt dat? Geen rimpel?

Gezien het geen erkende fout is (V, M) zou het interne error van de dispay kunnen betreffen. Ik daar wel wat stofopstapeling.

[Bericht gewijzigd door EricN op 10 januari 2021 19:35:28 (46%)]

Op 10 januari 2021 19:28:27 schreef EricN:
Ik stuur je de foto van de encoder door en je antwoord met de eigenschappen van de keuzeschakelaar.

Enfin, terug op het spoor

Ik heb je foto bewerkt. Kun je de rode cirkels extra aandacht geven. De foto is niet scherp genoeg.

Dit zijn de soldeerpunten van de trafo

De blauwe kader, kun je kijken waar die draden naartoe gaan?

Die gaan naar de keuzeschakelaar.

Het zou kunnen dat de keuzeschakelaar geen stroom draagt maar slecht ter encoding dient in de print zodat er zich op de kontakten oxidatie of vuil kan vestigen.

Krijg je de error ook op stand nul vd keuzeschakelaar? Ook na een hard reset?
Edit: ai, foto vergeten. Hier is hij:

Trek de voeler (ntc-ptc) eens uit. Krijg je de "M" foutmelding?

Die solderingen op de hoofdprint zien er echt goed uit, ik heb daar voldoende ervaring mee.

Idd die rode punten, trafo en 7805 zijn gevoelig voor slechte contacten

De keuzeschakelaar is dus niet stroomdragend. Kunje de verschillende kontakten nameten of ze nul ohm geven? (oxidatieopbouw of drg.)

Op 10 januari 2021 19:38:34 schreef EricN:
Trek de voeler (ntc-ptc) eens uit. Krijg je de "M" foutmelding?

Daar heb ik nu meer tijd voor nodig, eerst de boel weer in elkaar zetten.
Zodra is zover ben meld ik mij.

Morgen verder, ik moet even weg.
Nog bedankt.

Die foutmelding is altijd hetzelfde?? Lijkt of dat de processor random stopt.. Het is zeker geen standaard foutmelding, zou een echte letter moeten wezen of E met cijfers..

Warm eens de processor, display voeding ed met Fohn op en kijk of fout weer naar boven komt...

[Bericht gewijzigd door smd op 10 januari 2021 22:09:04 (22%)]

Probleem lijkt nu toch opgelost:

Met een scoop naar de 5 volt gekeken en er zat veel rimpel op.
Met een nieuwe elco achter de 7805 ging het al beter maar na het vervangen van de elco voor de 7805 is er geen rimpel meer te zien.
Na deze vervanging werkte de oven meteen zonder foutmelding.

Nog even duurtesten met wat lekkers. :)

Nog bedankt voor alle tips, dat werkt stimulerend en dat had ik nodig.

En kan je wat specifieker zijn welke capaciteit elco's hebben/ hadden zou moeten zijn...En dus duidelijk dat de processor van slag raakte...