ti 83 overclock

Omdat ik mijn rekenmachine altijd wat traag was, en omdat het geheugen laatst leeg was heb ik besloten hem maar eens over te clocken:

http://richfiles.solarbotics.net/Turbo83.html

Dit heb ik dus gedaan (weerstand en condensator in serie, waardoor ik nu de snelheid met een potmetertje kan regelen). Maar het probleem bij hoge snelheden is nu dat de processor het nog wel goed doet, maar het display kan het niet meer bijhouden. (de winst in snelheid is niet veel meer dan 50%, i.p.v. de 250% die zij beloven). Ik vroeg me dus af of er iemand hier ervaring mee heeft, en hoeveer hij in 30 seconde telt met dit progje:

while 1
x+1>x
disp x
end

Normaal kom je dan tot ongeveer 500-550. En de mijne kwam uiteindelijk bij 800 uit. Hoe snel is hij bij andere mensen?
Free the whales!
even mijn (niet geoverclockte ti pakken): 452 (ik heb er wel een ander OS op, dat vreet ook rekenkracht natuurlijk)

[Bericht gewijzigd door Bertrix op 27 maart 2005 10:25:10 ]

je hebt ook programma's om de lcd delay aan te passen, zodat de processor sneller kan gaan den de lcd : zie www.ticalc.org.

ik ken iemand die lcd delay eens op 2 had gezet, kwam er allemaal brol en lijnen op het scherm, dan gaat die aan de leerkracht vragen waarom het niet werkt :P

en ook eens, ik was firmware aant oversturen, komt die leerkracht: "geen rekenmachines in mijn les" trekt die de stekker toch wel uit... op die andere kwam daarna

Scherm1: "Bootloader error: Firmware entry point not found"
Scherm2: "Please Contact texas instruments"

[Bericht gewijzigd door Bertrix op 27 maart 2005 10:32:37 ]

ow ff zoeken dan, ik kan het niet echt vinden.
Free the whales!
http://www.ticalc.org./archives/files/fileinfo/349/34984.html (tis een asm programma, je hebt toch wel een (zelfgemaakte) linkkabel?)

[Bericht gewijzigd door Bertrix op 27 maart 2005 10:34:09 ]

Dat moet ik er dus opzetten, en dan kan ik hem dus nog wat verder overclocken?
linkkabel heb ik nog nie gemaakt, maar dat was ik al langer wel van plan. Is niet zo heel lastig, ff kijken of ik nog zo'n stekker heb.

over die firmware, dat kan toch niet met een ti83?

[Bericht gewijzigd door zweetvoetje op 27 maart 2005 10:36:32 ]

Free the whales!
nee twas met een ti83+
om dat te doen moet je een speciaal rpogramma(flash software op je ti zetten, dan kun je een nieuwe rom dump laden), gelukkig heeft dat ding een bootloader, en konden we opniew flashen, of die kon zijn rekenmachien weggooien...

[Bericht gewijzigd door Bertrix op 27 maart 2005 10:43:48 ]

Dat zal ik dan nog maar ff laten. Maar ik ga dan iig wel ff aan de slag met zo'n linkkabeltje. Ik heb al wel meer boeiende progjes gezien.

Ik heb trouwens ook ergens gelezen dat iemand beweerde zijn processor doorgebrand te hebben. Is dat een echt risico denk je? of valt dat wel mee.
Free the whales!
als je kortsluiting maakt, goed mogelijk. ik heb enkel ervaring met het overcloken van pic's, die houden er gewoon mee op als je te snel gaat...
Dat leek mij ook dat er zou gebeuren. Ik nam ook aan dat na een tijdje gewoon die dingen niet snel genoeg meer zijn.
Free the whales!
dat zegt de minimale lcd delay, dan weet je ook de maximum snelhied

dan kun je daarna met een hex editor de rom dump aanpassen(andere lcd delay) zodat de processor sneller kan.
Ik heb hier geen ervaring mee!
Op 27 maart 2005 10:23:12 schreef Bertrix:
even mijn (niet geoverclockte ti pakken): 452 (ik heb er wel een ander OS op, dat vreet ook rekenkracht natuurlijk)

ok, mijn niet overclockte 83+ kan in een halve minuut maar aan 366 geraken, kmoet wel zeggen, dat hij vol staat met games en andere rotzooi...


@zweetvoetje : welke os heb je staan?
Als ik op mijn 83 die code intik van dat programmatje.. krijg ik niks anders op me scherm dan 1E99.

Overigens zijn me batterijen zo goed als leeg.
Si vis pacem para bellum.
Interessant ik ben ook bezig om mijn Ti-83+ te overclocken. Ben er meteen een tutorial over aan het schrijven, zie hier:
http://www.linkkabel.nl/tutorials/ti83__overclocken.htm

Hoe heb jij die condensator los gekregen zonder schade aan te brangen (over verhitting)?
Hieper de piep!
Wel even vooraf de X op nul zetten.
Mijne ti83 komt ook aan 500.
Hm ik zal wel iets verkeerd doen maar hij blijft 1E99 geven tot ik op de ON toets druk.

code:
x=0
while 1
x+1>x
disp x
end

welke X moet er overigens gebruikt worden? de alpha x of de x onder het LINK knopje?

[Bericht gewijzigd door Miezjel op 27 maart 2005 12:56:08 ]

Si vis pacem para bellum.
Je moet typen

0 -> x

en dat zijn dezelfde x'en

x=0 is een test functie
kan dus nul of één geven.

[Bericht gewijzigd door reactokrato op 27 maart 2005 12:58:46 ]

en wat moet ik dan voor streepje hebben? de min of de (-) of nog een andere want nu doet ie het helemaal niet meer. :9
Si vis pacem para bellum.
Op 27 maart 2005 10:20:35 schreef zweetvoetje:
en hoeveer hij in 30 seconde telt met dit progje:

while 1
x+1>x
disp x
end

Normaal kom je dan tot ongeveer 500-550. En de mijne kwam uiteindelijk bij 800 uit. Hoe snel is hij bij andere mensen?

ik heb dat programmatje juist is uitgeprobeert en er komt alleen een kolom op te staan met telkens 10 onder elkaar
zo dus:
10
10
10
10
10
10
10
10
10
(ik gebruik overigens een TI84+ en geen 83 maar daar kan de fout toch niet liggen denk ik)
Met vriendelijke groet, Stynus ||| http://www.elektronicastynus.be ||| http://e-stynus.com ||| --> Automatische trapverlichting <--
dat > moet je zetten met de sto toets!
Dankje :D

ik kom ongemot (en zo goed als lege batt) op 426
Si vis pacem para bellum.
mijn batterijen zijn ook bijna leeg, als daar nu eens een accu inzat eh
Ik kom in 30sec met mijn Ti-83+ met bijna lege batterijen (geft dat telkens aan als ik dat ding aanzet) op 388...
Hieper de piep!