Philips ORT7500 Firmware

Op 14 januari 2021 23:09:00 schreef maartenbakker:
Hij heeft denk ik ook 5V nodig.

Ik had dus bij eerdere reacties gelezen dat de radio ook zou moeten werken met alleen de 12v voeding aangezien de 5v voeding enkel voor de usb poort achterop is.

maartenbakker

Special Member

Schema gevonden, zo te zien heb je gelijk. Blijft de 12V wel op spanning als je hem aansluit? Anders is je voeding misschien te licht.

[Bericht gewijzigd door maartenbakker op 14 januari 2021 23:53:16 (68%)

www.elba-elektro.nl | "The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."

Op 14 januari 2021 23:41:45 schreef maartenbakker:
Schema gevonden, zo te zien heb je gelijk. Blijft de 12V wel op spanning als je hem aansluit? Anders is je voeding misschien te licht.

Naar mijn idee wel ik heb hem aangesloten op de ingangen en nagemeten toen gaf hij een constante spanning van 12 volt.

Nou, ik heb dus ook zo'n ORT met hetzelfde euvel. Begin corona kaduuk, en gelijk een tweedehands besteld. En afgelopen kerst begaf die het ook. Zelfde symptomen: helemaal dood. Weer eentje in huis halen lijkt zinloos.

Dan maar de voeding vervangen. Beukenootje suggereerde een mooie voeding. Maar mijn soldeer-skills zijn niet meer zoals jaren geleden, dus keek ik uit naar een voeding met schroefcontacten. Het is de Mean Well RD-35A geworden. Te koop o.a. bij Ali, maar ik heb 'm wegens de verscherpte invoerbepalingen bij Conrad gekocht.

Jeetje wat een knoepert is die RD-35A! Daar had ik mij lelijk op verkeken. Ik heb het oude bevestigingsplastic eerst met een tang zo veel mogelijk verwijderd, en daarna met een mes verder gekortwiekt. De voeding aangesloten en 'm een beetje schuin min of meer op de oude plek geplaatst. Op de foto staat die nog recht, maar dat heb ik later wat aangepast. Dan heeft alles net iets meer ruimte. Uiteindelijk de voeding vastgezet met een lijmpistool. Een nog een plastic afscheiding gemaakt tussen de voeding en het 230V deel.

Dan kon de kast weer dicht. Shit, past niet meer. Die voeding is ook zo idioot groot. Totaal overgedimensioneerd. Maar met een beetje vijlen rondom het gat van de antenne-aansluiting ging die dicht.

En guess what? Hij speelt weer! Met al zijn oude nukken, maar wel, en daar gaat het mij om, met een mooi geluid, en met een externe antenne via een F-stekker. En de usboplaadfunctie werkt ook nog eens.

Same story. I have replaced with Meanwell RS 25-12 ( I don’t mind the lower output power ) with step-down converter 5V/3A. Cost 13€ totally.

Thevel

Golden Member

Ik heb hier ook zo'n rood geval met dezelfde klachten als de anderen.
Bij mij is het 6-potige 7110S1 IC defect.
Dus ook maar de voeding vervangen, ik had hier nog een TDK KWS15-12 module liggen (die levert 12V en geen 5V) dus geen USB maar die wordt nooit gebruikt.

Even een printje gefreesd (linksonder is nog niet gesoldeerd!)

De module.

En in de radio gemonteerd, door het zelf gemaakte printje kon ik hem vastzetten op de bestaande bevestigingspunten.
Enne... radio speelt weer als vanouds. :)

Mooie oplossing weer een rooie van de schroothoop gered.

Heb hier ook nog 1 liggen waarvan de display kapot is, zelf gedaan helaas
De volume en tuneknop werkten niet echt lekker dus die zou ik er even afhalen, telkens om de display gedacht, tot een onbedacht moment tijdens het desolderen iets teveel kracht en krak display kapot.
Dus als er iemand is die nog wat heeft liggen voor een schappelijk prijsje hou ik me aanbevolen.

vergeten

Golden Member

Op 11 april 2021 12:18:21 schreef beukenootje:
Mooie oplossing weer een rooie van de schroothoop gered.

....tot een onbedacht moment tijdens het desolderen iets teveel kracht en krak display kapot.

Dan was je tin niet gesmolten, desolderen doe je met een hete soldeerbout, eventueel wat tin toevoegen, niet met brute kracht! :)

Doorgaans schrijf ik duidelijk wat ik bedoel, toch wordt het wel anders begrepen.

Weet niet of het tin al gesmolten was, soms kom je wel eens een hand te kort
Ik desoldeer met een desoldeerpomp of litze, misschien eens zo'n tinzuiger die aan de bout vastzit, maar ja die zal ook wel weer problemen hebben, dit was gewoon dikke pech, en nee geen brute kracht kwam gewoon door de desoldeerpomp, die heeft net als een geweer een soort terugslag, display misschien beter even op een doekje gelegd, maar ja achteraf is alles heel gemakkelijk.
Maar goed is geen probleem op zich, heb nu sowieso een bijna complete radio als reserve.
Met goede originele voeding, dat dan weer wel.

Op 11 maart 2021 00:20:51 schreef Thevel:
Ik heb hier ook zo'n rood geval met dezelfde klachten als de anderen.
Bij mij is het 6-potige 7110S1 IC defect.
Dus ook maar de voeding vervangen, ik had hier nog een TDK KWS15-12 module liggen (die levert 12V en geen 5V) dus geen USB maar die wordt nooit gebruikt.

[bijlage]Even een printje gefreesd (linksonder is nog niet gesoldeerd!)

[bijlage]De module.

[bijlage]En in de radio gemonteerd, door het zelf gemaakte printje kon ik hem vastzetten op de bestaande bevestigingspunten.
Enne... radio speelt weer als vanouds. :)

Dat 6-potige ic lijkt mij een op-ampje die als comperator aan het transistordeel van de optocoupler hangt. Heel dat spul hangt wel aan het lichtnet, dus uitkijken met live-meten.

Waar het moederbord het meeste rookt, loopt ook de meeste stroom!

Heren!

Ik heb het probleem opgelost met de voeding :)

Omdat me het toch irriteerde was ik van plan om de voeding te reverse engineeren om te kijken of er een vervangende chip was.

Echter kwam ik er al snel achter dat de diode aan de chip stuk is, deze laat aan beide kanten geen stroom meer door. Deze is alleen voor het besturen van de MOSFET, zonder die diode reguleert het dus geen stroom

Deze (Diode D7) heb ik vervangen met een nieuwe SOD-123FL diode (De RB060MM-60TFTR in mijn geval, maar die is waarschijnlijk wat overkill) en de radio doet het al weer een uurtje lekker. Hiervoor was deze compleet dood

Ik zeg voor wie zijn radio nog heeft: Vervang lekker deze diode en heb er nog jaren plezier van _/-\o_

Ik hoor graag of iemand hier succes mee heeft

----

English for those looking through google:

If your Philips ORT7500 is no longer showing any signs of life because the power supply fails to output voltage: Try to replace the D7 Diode on the power supply.

Weer een ander foutje, mooi dat die weer gered is

Heb inmiddels ook alweer 1 gered De fet ligt finaal op sluiting en een SMD'tje verbrand

Waarschijnlijk komen er nog meer want er waren meer die de geest gegeven hebben.

Bedankt allemaal voor het delen van tips en ervaringen. Ik heb daarmee een ORT7500 kunnen repareren. Ik heb gekozen voor een voeding met gesloten metalen behuizing om EMI (storing) op de DAB+/FM banden te minimaliseren. Verder heb ik mij bediend van bedenkelijke mechanische bevestigingstechnieken.

Ik heb het reparatieverslag vastgelegd op:

https://photos.app.goo.gl/PU62kLCha961Wq857

Met vriendelijke groet,
Roland.

Netjes, mooi dat die weer werkt
Je had de voeding ook op de bodem van de kast kunnen plaatsen
Heb ik ook al eens met 1 gedaan, gewoon met dubbelzijdig plakband

Maar zo kan het ook, en je ziet er niks van als de kast dicht is.

En die schakelende voedinkjes willen echt wel storen, het is maar goed dat er geen MW en KG op deze radio's zit.

vergeten

Golden Member

Ik had er vorige week een om te herstellen in een repair cafe, is niet gelukt. Vandaag pas kwam ik dit al wat oudere topic tegen.

Helaas is hij afgevoerd door de "eigenaresse" die wilde dat er niet meer tijd aan werd besteed. Er is nog een kans dat ze ermee terugkomt als er met de echte eigenaar over is gesproken.

Heeft iemand al eens uitgezocht wat er nou defect is aan dat niet eens zo heel complexe SMPS voedinkje?

Doorgaans schrijf ik duidelijk wat ik bedoel, toch wordt het wel anders begrepen.

Zijn verschillende dingen, een diode aan de onderzijde van print de over een elco.
Heb al eens dat elcootje vervangen toen deed ie het ook weer
En ook al een paar die finaal ontploft waren, staat hier ook wel een foto van. helemaal zwart geblakerd en de fet volledig op sluiting.

vergeten

Golden Member

Radio is weer bij mij. Eigenaresse vond het toch de moeite waard om mij wat meer tijd te gunnen.

Verder in eigen topic.

https://www.circuitsonline.net/forum/view/157988/last

[Bericht gewijzigd door vergeten op 10 april 2022 19:46:19 (59%)

Doorgaans schrijf ik duidelijk wat ik bedoel, toch wordt het wel anders begrepen.
vergeten

Golden Member

De radio op 2 labvoedingen gehad,(om de defecte voeding te simuleren) hij doet dan wel wat er staat wat in de display verder reageert hij nergens op.
Bij nadere inspectie is de 17 polige flatcable naar de pcb flink beschadigd en zijn er enkele "sporen" onderbroken.
Is waarschijnlijk bij een eerdere onvoorzichtige kastopening gebeurd, de flatcable naar de display staat dan als eerste strak bij demontage van de achterwand. (repaircafe?) :(

Geheel vervangen is erg lastig, het front moet eraf en er is flink wat thermische lijm gebruikt bij de doorvoer naar het front. Voor je het weet is dan er nog meer schade.

Wie heeft praktische (ervarings)tips voor het aan een zijde herstellen van die flatcable?

Doorgaans schrijf ik duidelijk wat ik bedoel, toch wordt het wel anders begrepen.

Nog even dit topic aanhalen. Heeft iemand nog een werkende link waar ik een nieuwe voeding kan bestellen?

rob040

Golden Member

De originele voeding zul je nergens meer vinden.
Als ik even snel dit topic scan, dan zou je een voeding nodig hebben die +5V en +12V levert.
Die zijn wel te vinden.

Ook hebben sommigen de originele voeding gerepareerd.

maartenbakker

Special Member

Repareren zou m'n eerste keus zijn.

www.elba-elektro.nl | "The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."

Op 4 januari 2023 10:28:44 schreef saartje79:
Nog even dit topic aanhalen. Heeft iemand nog een werkende link waar ik een nieuwe voeding kan bestellen?

Zie mijn post van 8-4-2020. Ik heb de voeding hier besteld:
https://www.conrad.nl/nl/p/ac-dc-inbouwnetvoeding-open-mean-well-pt-65…
Hij is fors duurder geworden. Ik heb toen 27 euro betaald.
Succes.

maartenbakker

Special Member

Ik zou een (schakelende) 12V netadapter nemen en er voor de 5V een goedkope buck-converter achter hangen. Eventueel een 19V laptopvoeding en dan 2 buck-converters erachter, als je die toevallig hebt liggen. De buck converters passen in de radio en de externe voeding is ook nog redelijk handzaam en bovendien goedkoper dan zo'n Meanwell.

www.elba-elektro.nl | "The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."
maartenbakker

Special Member

Die ziet er van de bovenkant best goed uit, echter van de onderkant matig. Om aan de veiligheidsvoorschriften te voldoen is die waarschijnlijk alleen geschikt voor geaarde apparaten.

www.elba-elektro.nl | "The mind is a funny thing. Sometimes it needs a good whack on the side of the head to jar things loose."