Voeding kit XIAOLIN aangeboden op AliExpress


blackdog

Golden Member

Hi Kruimel,

Waarom gebruik je de MOSFet regeling niet op de manier waarvoor hij bedoeld is?

Instelling
Waarom zou de ventilator uit moeten zijn, terwijl die ventilator op laag toerental vrijwel zeker onhoorbaar is?
Je test met een regelbare voeding wanneer de ventilator betrouwbaar start vanuit de stilstand als je de voeding er in 1x op set.
Kijk naar de spanning die daar nodig voor is, en ga dan een stukje hoger zitten dan de betrouwbare opstart spanning als je de weerstandswaarde
gaat bepalen voor de basis draaisnelheid.

Betrouwbaarheid
Met deze opset is het zeer betrouwbaar met een normaal gesproken vrijwel een onhoorbare ventilator.
(ik ga er vanuit dat je de goede ventilator voor jouw toepassing hebt gekozen en niet een ventilator uit een dikke Server gebruikt)

Bij het inschakelen gaat de ventilator even vollop draaien door de elco over de NTC, dan weet je altijd dat de ventilator nog werkt,
en zakt dan naar de basis snelheid.
Bij een goede ventilator verslijt jij hem niet, dit door het lage toerentaal dat gemiddeld gebruikt wordt.

Voordelen van draaiende ventilator
Die minimale draaisnelheid van de ventilator houd je voeding koeler, betrouwbaarder en stabieler!

Mijn 2 cent.

Groet,
Bram

Waarheden zijn "Illusies waarvan men vergeten is dat het illusies zijn"

Misschien heb ik het een beetje onhandig verwoord, de bypass weerstand R3 is gewoon gemonteerd en de fan draait altijd, maar ik wil niet dat hij bij temperaturen onder 50 a 60 graden al versnelt omdat deze fan dan al snel luider wordt. Ik ben nu juist bezig (door de aanschaf van een 100kΩ NTC) de schakeling meer in overeenstemming te laten zijn van de originele schakeling die je publiceerde. :)

De fan die ik gebruik betreft een processorkoeler van een Pentium 4. Dat zijn strict genomen geen slechte fans, ik heb goede ervaringen met Intel stock-koelers. Deze specifieke generatie is helaas niet bepaald stil, en ik probeer de instelling zo te kiezen dat hij bij gewoon gebruik niet versnelt. Ik geloof niet dat een transistor in het bijzonder last heeft van een TC van 60 of 70°C.

blackdog

Golden Member

Hi Kruimel,

Ik zie graag hoe jij het hebt opgelost, zodat ook anderen dat ook weer kunnen gebruiken voor hun voeding :-)

Een minder stijle MOSFet werkt wat beter en je kan als je daar zin in hebt, ook een parallel weerstand gebruiken aan je NTC om de stijlheid wat minder te maken.
Dit om het een en ander meer in overeenstemming te brengen met jouw koelomgeving.

Groet,
Bram

[Bericht gewijzigd door blackdog op 29 november 2019 16:22:17 (47%)]

Waarheden zijn "Illusies waarvan men vergeten is dat het illusies zijn"

Daar zat ik ook al over te denken, voornamelijk om te verhinderen dat de fan gaat jagen. Op dit moment lijkt de stabiliteit redelijk, dus ik weet niet of ik dat verder ga optimaliseren. Ik gebruik op dit moment een IRFZ34 MOSFET, en dat lijkt aardig te voldoen, ik heb die niet vergeleken met andere exemplaren om de stijlheid vast te kunnen stellen. Ik zal daar later nog wel eens kijken, dit project ligt niet bovenaan de stapel.

In de post over de fanregeling die ik eerder deed waren de wijzigingen al wel te zien, maar ik heb ze nooit duidelijk ingetekend, even inhalen dus :):

De wijzigingen zijn zo veel mogelijk gedaan zonder de PCB aan te passen, daarom staan sommige onderdelen wat raar. De elco die in jouw schema C4 heet staat op de footprint waar eerst T3 stond en is via een link op de plek van de ongenummerde 2k7 weerstand verbonden met de schakeling, en ik gebruik diens negatieve pootje om naar de aansluiting van de NTC te springen. Die is nu 470µF omdat de schakeling nog ingericht is op een 10kΩ NTC, maar daardoor wordt hij eigenlijk te groot. Een kleinere capaciteit zou moeten voldoen met een 100kΩ NTC, ik denk dat met een kleine diameter fan 47µF ruim zat is. Omdat mijn fan ook niet een enorme stroomvreter is heb ik C5 (wederom op jouw schema) vervangen met de 220µF. Eventueel kan je C5 (originele schema) gebruiken, want die lijkt geen zinvolle functie te hebben.

PS De elco over R8 heeft geen nummer/informatie, en staat ook niet op de print.

Kitje is binnen en bc108 is ook langs geweest en die heeft wat leuke dingen achter gelaten.
Zie de foto's
Volgens mij heb ik genoeg wikkeldraad om te proberen de ringkern te wikkelen naar
de spanningen zoals aangegeven in het schema.
Verder een bomvrije plaatstalen behuizing welke ik prima kan gebruiken en een lekker
groot koellichaam.
Helaas moet het project even op de plank omdat ik eerst iets anders moet gaan doen en
wellicht heb ik daar misschien jullie hulp bij nodig, eerst zien hoever ik kom.
bc108 nogmaals bedankt voor alles.

Gr, Joost

Alles begint met respect.

Ja je ziet dat ook terug in tal van andere voedingen en Pc-voedingen; De ventilator draait altijd, maar op een heel laag onhoorbaar pitje.

Pas als de temperatuur daadwerkelijk stijgt, gaat ook de ventilator iets hogere toerentallen maken. Er is altijd wel enige opwarming bij heel laag gebruik, dus zo blijft alles koel.

A good housewife opens the fridge-door at zero cross point of AC cycle.

In dit geval was mijn enige motief eigenlijk om te verhinderen dat de fan in het stuk van zijn bereik zou werken waar die loopt te piepen en kreunen. Dat doet hij tussen de 2 en 4V, en is duidelijk hoorbaar. Ik vond het ook niet handig om een hysterese in te bouwen dus de schakeling van blackdog was eigenlijk vanaf het begin af al optimaal. Wel moet ik zeggen dat ik bij de CO2016 voeding een fannetje heb ingebouwd met een (ingekochte) andere schakeling, en dat ik die in stationair draaien wel een beetje te luidruchtig vind en dat meer is geworden. Ik denk dat ik die op een dag nog zal 'retro-fitten' met deze schakeling.

Na een kleine vertraging is het eindelijk toch gelukt.
Print is gesoldeerd en de trafo is gewikkeld.
Het kitje was helaas niet kompleet R24 en R25 ontbraken. maar ik heb uiteraard een
aantal vragen.
Ook ik heb D1 en D2 vervangen voor een brugcel maar ik twijfel of ik dat goed gedaan heb

Dan heb ik nog een vraag hoe ik de potmeters moet aansluiten ik zag dat
er maar 2 draden naar de potmeters gaan.
Ik heb een tekening bijgevoegd welke van de twee moet ik gebruiken ?

Dan de instel potmeters zoals VR1 t/m VR5 moet ik daar wat mee doen en zoja
wat moet ik daar dan mee doen ?

Gr, Joost

edit : PDF vervangen voor JPG

Alles begint met respect.

De brugcel zit goed, maar vraag me af of de elco's ernaast nu nog wel passen. De KBP310 is namelijk nogal dik.

flash2b bedankt voor je antwoord.
Ruimte valt mee,

Gr, Joost

Alles begint met respect.

Mooi opgelost met die brugcel, ik zat me pas veel later te bedenken dat deze locatie zich heel goed zou lenen voor een standaard platte brugcel, maar toen had ik er al die rond in gemaakt, die op geen enkele manier echt praktisch was.

Je kunt beide schakelingen gebruiken voor de potmeters, maar ik zou gaan voor optie B. Beide zullen namelijk hetzelfde doen (de weerstand tussen de 0 en 10kΩ variëren, maar als de contactarm op een bepaald moment eens slecht contact maakt dan maakt dat het verschil tussen een voeding die naar de max spanning schiet, of nog hoger (in verzadiging). Bij goede potmeters is het contactprobleem wat minder, al moet ik zeggen dat ik met deze potmeters geen problemen heb ondervonden.

@Kruimel,
Dank je, ik had ook nog een ronde brugcel in het bakje liggen maar deze
platte leek eigenlijk te passen zonder aanpassingen dus voor de platte gekozen. :)

Hoop dat ik 1 dezer dagen het geheel kan samenbouwen voorlopig gewoon op een
plank om te kijken of alles wil werken.
Neem aan dat ik de aansluiting op de print voor de ampere meter gewoon kan doorverbinden ?

Jij nog een idee wat de instelpotmeters doen (VR1 t/m VR5) ?

Gr, Joost

p.s. ben ik nog de enige die met deze kit bezig is O-)

Alles begint met respect.

Nee, je bent in elk geval niet de enige.
Ik moet nog een printje etsen voor de hulpvoeding voor de digitale meters.
VR1 en 2 zijn voor de max instelling van spanning en stroom.
VR3 en 4 zijn voor de relais schakelpunten.
VR5 is voor de fan.

Op 17 mei 2020 15:13:21 schreef TO-92:
@Kruimel,
Dank je, ik had ook nog een ronde brugcel in het bakje liggen maar deze
platte leek eigenlijk te passen zonder aanpassingen dus voor de platte gekozen. :)

Ik had ook zo een platte liggen... 8)7

p.s. ben ik nog de enige die met deze kit bezig is O-)

Geen idee hoeveel mensen hem überhaupt hebben gekocht, maar ik heb hem al af en vastgesteld dat ik er geen behuizing voor ga opofferen. Ik heb nog een CO 2016 voedingskit liggen waarvan ik weet dat die zonder wijzigingen beter werkt, en ik moet mijn 2 CO 2019 voedingen ook nog afwerken (mijn vorderingen zijn hier te zien). Misschien kan ik een deel van de componenten hergebruiken voor andere projecten. Bijna alle componenten om er een mooie voeding van te maken zitten er zo te zien al op, maar ik heb nu teveel wijzigingen aan de print moeten doen om er nog blij van te worden. De meeste onderdelen lijken van redelijke kwaliteit.

@Zonnepaneeltje,
Dank voor je antwoorden betreffende de instel potmeters.
we in iedergeval met zijn tweeën :)

@Kruimel,
dat topic heb ik doorgelezen maar iet teveel van het goede voor mij.
Wel een mooi frontpaneel heb je daar.

Alles begint met respect.

help

Hij werkt maar volgens mij niet helemaal zoals het moet, de situatie

Uitgang trafo spanningen zijn 15,44 24,64 en 35,33 Volt.
Als ik de voeding aanzet dan is de spanning met beide potmeters helemaal dicht
zonder belasting 3,0822 Volt en als ik dan vervolgens de potmeter voor de
spanning geheel open draai dan is de spanning 40,700 Volt.
Tevens brand de LED voor de stroom begrenzing continue maar als ik een belasting
aan de voeding hang (halogeen lampje 12 Volt 10 Watt) en ik vervolgens de potmeter
voor de stroom terug regel gaat de LED op het punt waar de stroombegrenzing
ingrijpt feller branden.
Ik heb dus ergens iets niet goed gedaan is er iemand die mij de goede richting
op kan sturen waar ik eventueel de mist in ben gegaan ?
Ik weet dat de glazen bollen momenteel slecht leverbaar zijn maar ik weet niet
waar ik moet beginnen.

Gr, Joost

Alles begint met respect.

Hoi Joost
Denk niet dat je iets verkeerd heb gedaan
Misschien een andere led ?
Ik gebruik hier voor een blauwe heeft volgens mij een hogere spanning nodig

Oef, dat is lastig, ik herken de symptomen zo snel niet om eerlijk te zijn. Wat is de spanning over D9 en D10? Dat zijn de voedingsrails van de hulpspanning en die moeten goed zijn en gescheiden van de hoofdvoeding. Zijn die dat niet dan moeten we die apart gaan controleren.

Als dat goed zit zou ik eens kijken naar de LED. Het lijkt er een beetje op dat de LED in 'reverse' ook geleidt. Ik zie nu pas dat die LED tot 20V in 'reverse' op zijn mik kan krijgen, en daar kunnen ze niet altijd tegen (al gaat het meestal wel goed). Als de LED in tegenrichting geleidt werken de opamps elkaar tegen, dus ik zou de LED eerst een desolderen en meten of de uitgangsspanning dan wel normaal regelbaar is. Let er wel op dat de uitgang dan niet meer stroombegrensd is, dus voorkom kortsluiting!

Als dat werkt zou ik de LED vervangen met een nieuwe en een diode (een 1N4148 bijvoorbeeld) in serie zetten zodat de LED de spanning in tegenrichting niet meer helemaal zelf hoeft te blokkeren en dan opnieuw testen. Eventueel kan je het zonder LED ook wel testen, maar dan heb je geen overstroomindicatie.

Het kan natuurlijk ook een ander probleem zijn, maar daar kijken we wel weer naar als de bovenstaande problemen zijn bekeken.

@bc108,
Marcel blauw vind ik wel een mooie kleur maar niet als LED
Had een externe schijf met een blauwe LED erin daar heb ik een
stukje zwarte tape overheen geplakt.

@Kruimel,
En dat ging helaas niet goed.
Ik had beide potmeters helemaal dicht staan vervolgens de spannings
meter langzaam open gedraait en ok alles zoals het was, dit ter
kontrolle.
potmeter weer dicht, voeding uit en vervolgens de connector van
de LED losgehaald, voeding weer aan met mijn ogen op de meter
om te kijken of de spanning weer rond de 3 Volt zou uitkomen.
Zie in mijn linker ooghoek een flitsje en hoorde (volgens mij) iets
springen.
Voeding weer uitgezet, geen rook te zien en geen brandlucht.
Connector van de LED weer ingestoken en weer spanning erop nu
begint 1 van de relais te klapperen als ik de spanning omhoog draai.
Helaas moet ik het hier even bij laten omdat mijn hoofd het toelaat nog iets te doen, sorry

Gr, Joost

Alles begint met respect.

't Is niet erg, we kijken er wel weer naar als je weer op orde bent. Mocht je weer aan de slag kunnen zou ik het volgende doen:

  • De U3 (een 7812) los solderen. De relais worden dan niet meer aangestuurd en je bent dan van het geklapper af. Je voeding zal dan niet meer gebruikt kunnen worden boven de spanning die dan van je elco's komt, maar voor testen is dit geen probleem;
  • Meet de spanningen over de zeners van daarnet. Als die defect zijn krijgen de ICs een te hoge spanning en kunnen daardoor overlijden. Dat zou hier een factor kunnen zijn geweest;
  • Check of de regeling zonder de LED wel werkt, zo niet dan moet je even kijken wat de spanning op pin 7 van IC1 is. Is die ongeveer -5V (tov de '+'-uitgang) dan probeert de opamp de spanning wel omlaag te brengen en is de diode waarschijnlijk beschadigd of slecht gesoldeerd.
  • Is de spanning (significant) hoger dan -5V, dan moet je eens controleren wat het spanningsverschil tussen pin 5 en 6 is. Is dat positief dan is er iets mis in het terugkoppelingsnetwerk en is het niet de fout van je opamp. Is dat negatief dan moet je eens kijken or R4 de juiste waarde heeft.

Kom je met deze tests rare dingen tegen zijn wij daar natuurlijk nieuwsgierig naar!

@Kruimel,

Ben er weer, wat heb ik gedaan.

U3 = LM7812 los gesoldeerd.
Zener spanningen gemeten over D10 staat 8 Volt en over D9 staat 6,22 Volt.
Met de LED aangesloten regelt de voeding tussen 3,06 en 19 Volt en de 19 Volt heb ik
bij de spannings potmeter 3/4 open gedraaid.

Met de LED los regelt de spanning tussen 7,62 en 19 Volt maar bij een kwartslag
open zit ik al op de 19 Volt dus echt regelen kan je het niet noemen.
De spanning van pin 7 t.o.v. + uitgang is + 0,41 Volt
Spanningsverschil tussen pin 5 en 6 is 0,00 Volt.
Dit gemeten op IC U1.
R4 is volgens de kleur codering 3K en gemeten 3,02K

Hoop dat je hier iets aan hebt.

Gr, Joost

Alles begint met respect.

6,22V over D9 is veel te weinig. Zit het daar wel goed bij de gelijkrichting bij die trafo? Welke spanning meet je over C2?

Het is wel apart dat je precies 6,22V op de plek van D9 meet, het impliceert dat je misschien de 6,2V zener op de verkeerde plek hebt staan, ik zou dat even proberen te checken.

Ik vermoed dat hier sprake is van oscilleren, zou je de uitgang eens kunnen meten met je meter op AC? Het feit dat er tussen pin 5 en 6 0V staat lijkt er op te wijzen dat de opamp in elk geval een goede poging doet om de spanning te stabiliseren, maar dat er iets mis gaat in de terugkoppeling of de regeling van de uitgangstransistoren.

Enfin, eerst de voeding goed krijgen. Meet de spanning over de hulptrafo eens, als daar geen 12V uit komt gaat er sowieso niets goed, en dat lijkt me handig om eerst eens bevestigd te hebben.

Vervolgens moeten de spanningen over C1 en C2 worden gecontroleerd. Uitgaande van een 2x12V trafo verwacht ik daar iets van 18-20V. Als dat serieus minder is moet je dat eerst op orde brengen. Daarna zouden de zenerdiodes de spanning omlaag moeten brengen naar 15 respectievelijk 6,2V, daar lijkt sowieso al wat mis te zijn dus die componenten zijn verdacht. Ik zou prioriteit geven aan het proberen goed te krijgen van de hulpvoeding. Zo lang die niet goed is kom je sowieso nergens.

@Zonnepaneeltje en Kruimel,

Trafo spanningen zijn 12,23 en 11,93 Volt AC
Over C1 meet ik 15,81 Volt en over C2 15,82 Volt die zijn dus te laag.
Kan de brugcel eventueel niet goed zijn ?
Ik zal D9 en D10 voor de zekerheid vervangen voor nieuwe zeners en dan
kom ik terug met nieuwe metingen want toen ik de voeding zonder LED aan gezet
heb kwam uit die buurt het lichtflitsje wat ik een paar posts hierboven vermelde
vandaar dus ik ga ervan uit dat minimaal 1 van de 2 defect is.

Gr, Joost

Alles begint met respect.

@Kruimel,
Deze was ik vergeten te beantwoorden,

Op 5 juni 2020 21:39:26 schreef Kruimel:
Ik vermoed dat hier sprake is van oscilleren, zou je de uitgang eens kunnen meten met je meter op AC?

Twee metingen de eerste met de spannings pot. open en die van de stroombegrenzing dicht.

En de tweede met beide potmeters helemaal open.

Hoop dat je er iets mee kan?

Gr, Joost

Alles begint met respect.