welke fototransistor ?

trix

Golden Member

hallo,
dit is een onderdeel van een groter project waar hier al diverse topics over gaan.

ik ben op zoek naar een fototransistor of foto diode die een digitale input hoog/laag maakt op een atmega2560.

ik doe het nu met een TSOP4836, en dat werkt wel, maar de snelheid is waarschijnlijk te beperkt.
ik wil nu een test doen met een foto diode/transistor.

de (zender) is een TSAL6100 met een golflengte van 940 nm.
gewenste kijk afstand is 80 cm.
welke foto diode/transistor zou hier voor bruikbaar zijn ?

eigenwijs = ook wijs

Ha trix,

Even op de data sheet gekeken maar deze is 15 ns wat had je in gedachte ?

Groet,
Henk.

Everything should be as simple as possible, but not simpler.
trix

Golden Member

welke is 15 nS ?
ik heb 4 mS de tijd om te zien of de diode/transisor hoog of laag is.

edit:
ik zit nu te bedenken dat ik eigenlijk helemaal niet vastzit aan die TSAL6100 (zender) mag ook een andere LED zijn.
het is alleen om te testen.

wat ik eigenlijk wil testen, is hoeveel omgevings licht invloed heeft op de schakeling.

[Bericht gewijzigd door trix op 25 oktober 2020 18:57:17 (16%)]

eigenwijs = ook wijs

Ha trix,

Met jou eisenpakket is de diode ruimschoots bruikbaar Tr hoog/laag is 20/80 Tr 15 ns en als je niet teveel lading verplaatst is 100 us Tp haalbaar dit is dus ruim binnen de 4 ms.

Wow wacht even aanvullende vraag moet ik even kijken op het data blad.
Tja goed lezen is toch wel belangrijk :+ ik keek naar de zender |:(
Nee die ontvanger is niet bruikbaar dat wil zeggen als je gebruik maak van een 38 kHz toon draaggolf wel maar ik verwacht ik niet.
Ik ga voor een andere kijken tot later.

Groet,
Henk.

[Bericht gewijzigd door electron920 op 25 oktober 2020 19:25:39 (30%)]

Everything should be as simple as possible, but not simpler.

Op 25 oktober 2020 18:29:42 schreef trix:
ik doe het nu met een TSOP4836, en dat werkt wel, maar de snelheid is waarschijnlijk te beperkt.

Strange dat je dat vraagt, een TSOP4836 reageert volgens de datasheet in 15/fo = 15/36000 = 0.4mS en dat is het maximum, normaal ligt dat tussen de 7/fo en 15/fo of tussen de 0.2mS en 0.4mS.

Heb je problemen met die TSOP?

LDmicro user.
Lambiek

Special Member

Een Tsop moet makkelijk kunnen. Als de golf gemoduleerd wordt, heb je ook geen last van omgevings licht.

Als je haar maar goed zit, GROETEN LAMBIEK.

Ha trix,

Even naar de diode gekeken die ik meestal gebruik dat is de BPW34.
Die is te gebruiken Tr 100 ns donker stroom 30 nA en een gevoeligheid van 1 mW / cm^2 bij een golflente van λ 950 nm met een openingshoek van + / - 65°

Ps, de opmerking van @Lambiek is helder en als je systeem daar geen problemen mee heeft te gebruiken alleen een andere zender er bij.

Groet,
Henk.

[Bericht gewijzigd door electron920 op 25 oktober 2020 19:48:32 (21%)]

Everything should be as simple as possible, but not simpler.
trix

Golden Member

4 mS om te kijken of TSOP licht of donker is, vervolgens 400 mS rust gaat goed.
bij 200 mS rust komen de 1e fouten.
en bij de gewenste snelheid van 100 mS rust zie ik te veel fouten.

wat is een fout: de TSOP word niet voldoende belicht om de output naar "0" te sturen. (licht = "0" donker = "1").

elektron, bedankt voor de inzet.
ik wou eigenlijk gewoon eens een andere insteek proberen.

eigenwijs = ook wijs

Volgens mij zijn ze niet goed uitgericht, ik herinner mij nog dat je buisjes hebt gemaakt, ligt het daar niet aan?

LDmicro user.
trix

Golden Member

de TSAL 6100 (zender) word met een serie weerstand (180 ohm) rechtstreeks met een pin v/d atmega 2560 aan gestuurd.
dit geeft een stroom van 27 mA.
ik kan met de stroom nog iets omhoog, ,oschien dat eens testen.

eigenwijs = ook wijs
trix

Golden Member

post gekruist.

ìk denk dat dat uitrichten niet zo nouw komt, de kegel v/d tsal is nogal groot. maar ik ga dit ook eens bekijken, tnx.

even voor het geheugen :)

[Bericht gewijzigd door trix op 25 oktober 2020 20:16:16 (14%)]

eigenwijs = ook wijs

Als je de snelheid test moet je dat doen zonder obstakels dan pas kun je weten wat er eventueel in de weg zit.

De stroom door de TSAL is (5V-1.3)/180 = 20mA en geen 27mA en ik weet niet wat de max stroom is uit een Atmegapoort.

LDmicro user.
trix

Golden Member

ja snelheids test is zonder iets er tussen, dus alle TSOP's licht.

klopt,..die 1,3 vergeten |:(
max. stroom is dacht ik 20mA per pin. maar omdat er maar 1 pin tegelijk hoog is kan de stroom ook omhoog, ik dacht iets van 40 mA per pin.

[Bericht gewijzigd door trix op 25 oktober 2020 20:27:08 (17%)]

eigenwijs = ook wijs
Sine

Moderator

Die TSOP-jes zijn heel goed in vangen wat ze moeten vangen, als je ze maar voert wat ze verwachten.

trix

Golden Member

ik gebruik alleen de draaggolf van 36 kHz. dus geen gemoduleerde signalen o.i.d.

eigenwijs = ook wijs

Op 25 oktober 2020 20:24:01 schreef trix:
ja snelheids test is zonder iets er tussen, dus alle TSOP's licht.

Obstakels zijn ook die buisjes waarin ze zitten, je weet immers niet hoeveel licht die TSOPs ontvangen en of het al of niet gereflecteerd licht is.

Op 25 oktober 2020 20:03:34 schreef trix:

bij 200 mS rust komen de 1e fouten.
en bij de gewenste snelheid van 100 mS rust zie ik te veel fouten.

wat is een fout: de TSOP word niet voldoende belicht om de output naar "0" te sturen. (licht = "0" donker = "1").

Zolang je niet zeker bent hoe je aan die tijden komt is een andere fotocel is volgens mij niet aan de orde.

LDmicro user.
Sine

Moderator

Op 25 oktober 2020 20:59:41 schreef trix:
ik gebruik alleen de draaggolf van 36 kHz. dus geen gemoduleerde signalen o.i.d.

Well there's your problem.

@trix, @Sine,

Ik was even weg maar..... dat is wat ik aangaf @trix je moet dan wel je zender aanpassen dus er een nemen die ook 30 kHz als draaggolf genereert of je doet dit software matig maakt niet uit.
In de ontvanger die je gebruikt zit een data slicer :D vandaar dat de opmerking van @Lambiek een helder verhaal is.

Groet,
Henk.

Everything should be as simple as possible, but not simpler.
Sine

Moderator

Na een topic of drieëndertig weten we denk ik ondertussen al dat die tsop zo ongeveer de minst geschikte ontvanger is voor deze toepassing.

- Hij heeft een ingebouwde AGC en vangt daarmee alles wat een beetje op een geldig signaal lijkt
- Hij wilt een gemoduleerd signaal zien, maar hij onderdrukt een continue draaggolf.
- Hij heeft geen harde drempelwaardes waarop hij schakelt, dus een reflectie die op een buurman terecht komt wordt even hard gedetecteerd (weer dankzij die AGC)

Allemaal geweldig als je een afstandsbediening wilt kunnen vangen onder de meest barre condities, maar hier is het ding gewoon niet voor gemaakt.

Dat probleem van het filteren kom je misschien nog aan voorbij door het gemoduleerde signaal te moduleren met 1/10e van de draaggolf.
Maar het blijft houtje-touwtje.

[Bericht gewijzigd door Sine op 25 oktober 2020 21:32:57 (12%)]

Hi Trix,

Eerder ook al na gemeld, probeer een detector uit de tssp serie ipv de tsop serie.

Die hebben niet zoveel rust nodig.

PA0EJE - www.eje-electronics.nl - e.jongerius[aapje]eje-electronics.nl - EJE Electronics - Elektronica/firmware ontwikkeling

Je zou nu ook een testbordje kunnen maken waarmee je elke verbinding apart kunt uittesten, het zal wel wat tijd kosten maar dat zal later ook nog bruikbaar zijn voor het uitlijnen.
Misschien komen er dan andere fouten tevoorschijn zoals storingen op de voeding, programmeerfouten enz...

Een andere fotocel zou ik niet direct kunnen aanwijzen zonder dat je nog een hoop elektronica erachter moet plaatsen.

LDmicro user.

Ik heb hier verschillende projectjes liggen die werken met dezelfde componenten, één ervan is een geweer dat telkens bij het schieten eenmalig 0x55 (01010101) verzendt in IR en als 2400b uart code.

Als ik het goed heb is 1bit hiervan zo'n 0.4mS lang en geen enkele keer heb ik de opstelling weten fouten al stond de TSOP ontvanger 8m ver.
Ik kon vanop afstand de hits resetten door de knop van het geweer 2sec in te drukken, dan werd er constant met enkele tientallen mS tussenpauze 0x41 of 01000001 of 'A' verzonden, ook dat werkte altijd.

Er moet volgens mij iets mis zijn aan de opstelling in de hoop dat de software goed werkt.

LDmicro user.
Lambiek

Special Member

Op 26 oktober 2020 09:01:35 schreef MGP:
Er moet volgens mij iets mis zijn aan de opstelling in de hoop dat de software goed werkt.

Inderdaad, ik gebruik die dingen ook veel nooit problemen mee.

Maar je moet wel het protocol aanhouden, anders krijg je wel problemen. Als je niet gecodeerd verstuurd reageert het al op zonlicht.

Als je haar maar goed zit, GROETEN LAMBIEK.

Op 26 oktober 2020 09:10:18 schreef Lambiek:
...
Maar je moet wel het protocol aanhouden, anders krijg je wel problemen. Als je niet gecodeerd verstuurd reageert het al op zonlicht.

Dat dacht ik vroeger ook maar dat is niet het geval, ik heb dat toen getest en geschreven in één van zijn vorige topic's.

Maar zoals we vroeger al aanhaalden heeft de TS volgens mij te snel willen werken en teveel stappen overgeslagen zodat hij nu in het duister tast waarom het niet werkt en als je onderdelen begint te vervangen zonder de oorzaak te kennen is de weg nog heel lang.

Ik geef enkel maar aan wat ik ervan denk en ervaren heb en heb veel bewondering voor wat de TS al verwezenlijk heeft, petje af.

EDIT:

@TS. Je hebt een logic analyzer volgens lezen, wat zegt die ervan als je die aansluit op de zender en ontvanger?

LDmicro user.
trix

Golden Member

Even kort vanaf de telefoon.
Ik heb nog steeds vertrouwen in de TSOP, al is dat niet gebaseerd op kennis of ervaring.
Deze heb ik o.a. in de beginne gekozen omdat ik dan snel iets werkende had waarmee ik verder kon. Dat is nu gepasseerd, en nu ik de scan snelheid wil opvoeren kom ik wat problemen tegen. Wat kleine dingen geprobeerd, en hier nog een paar suggesties gekregen om nog te proberen, waarvoor mijn dank.
Maar ook dacht ik, ik heb nog geen andere zenders en ontvangers getest.

eigenwijs = ook wijs