Verschil tussen een 78xx en een LM317.

Die commando's staan neem ik aan in het manual.

In de manual van de Keithley 2000, wel te verstaan. De eerste console geeft gewoon door wat jij intikt, en de tweede toont de reactie v/d Keithley.
Als je een bestand maakt met opdrachten (noem het bv. input.txt) en je wil de antwoorden opvangen in een ander bestand (bv. result.txt) kan je de boel zo automatiseren:

Tweede console: cat /dev/ttyUSB0 > result.txt
Eerste console: cat input.txt > /dev/ttyUSB0

Ondertussen heb ik de oorzaak v/d meetfout bij de ADC gevonden. Diens ingangen zijn niet hoogohmig: 2.4M.
Nu heb ik --een beetje onnadenkend-- een weerstandje van 1k in serie met de ingang geplaatst. En dat levert uiteraard een meetfout op van 1/2400 - dat is 166µV bij een te meten spanning van 4V!
Dat wordt dus bufferen, want de uitgangsspanning v/d labvoeding kan ik enkel via een spanningsdeler meten.
OPA277 zei je?

[Heb je die Arduino al terug aan de praat?]

Prosper, yop la boum, c'est le roi du macadam (aldus Maurice Chevalier)
fred101

Golden Member

Arduino is nog dood maar ik heb een paar lege atmels en een vriend met 5 van die dingen wil wel proberen een bootloader er in te zetten als ik kan vertellen hoe. Dat moet ik nog uitzoeken.

Die OPA is de opvolger van de OP177. Een opamp met 0,5uV/C drift.

Ik heb de 2000 aangesloten op de computer. Windhoos doet niks. Hij start de testpoint software, geeft geen error als ik com3 kies met de rs232/usb kabel eraan maar verder gebeurd er niks. Hij wilde natuurlijk herstarten om de drivers te laden maar vervolgens gebeurd dat volgens mij niet.

Toen in Linux. Jou commando's gegeven (ook zonder extra commando) maar dan krijg ik een vierkante cursor en kan dingen intypen en er verscheen remote in de Keithley Display. Leuk, dat was hoopvol, manual erbij en daar staan VB programma voorbeelden en er staan commando's in (die erg lijken op de commando's in jou software) Maar ik heb geen idee over hoe en wat en de preciese syntax of volgorde.

Ik heb van alles geprobeerd, op een gegeven moment stond de meter ipv in 0.1V in de 1V range dus blijkbaar is er ergens communicatie geweest. Als ik de USB er uit trek protesteert linux en zegt dat er een sessie bezig is. Maar ik zie niks verschijnen in de andere terminal (behalve als ik in de andere wat fout doe dan reageert hij met een communicatie error.

De pest is dat ik niet weet of ik iets fout doe met de stty instellingen of een syntax error of dat het gewoon niet werkt.
Ik ga maar eens googlen.

www.pa4tim.nl, www.schneiderelectronicsrepair.nl, Reparatie van meet- en calibratie apparatuur en maritieme en industriele PCBs
flash2b

Special Member

Moet je niet eerst de baudrate enzo. goedzetten in de 2000?

Eens kijken...

19200bd is het hoogste dat de Keithley aankan - hij staat default op 4800bd. Ik zou in eerste instantie de baudrate op de Linux-bak aanpassen. Als later blijkt dat het sneller moet, kan het nog aangepast worden.
De RS232-interface moet wel geactiveerd worden op de Keithley - default = inactief.

Hardware-handshaking wordt niet ondersteund. Ik denk niet, dat zoiets mogelijk is met een USB/RS232-verloopdingetje. Misschien toch even controleren:

code:


epona/pros: stty -F /dev/ttyUSB0 -a
speed 38400 baud; rows 0; columns 0; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; flush = ^O;
min = 1; time = 0;
-parenb -parodd cs8 hupcl -cstopb cread clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany -imaxbel -iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke

Belangrijk:
-crtscts : hardware-handshaking = OFF
ixon : software handshaking = ON

EOL-termination:
In mijn voorbeeld hierboven is olncr actief. Die vertaalt een nette '\n' naar dat rare '\r\n'. Nakijken.

Ik heb van alles geprobeerd, op een gegeven moment stond de meter ipv in 0.1V in de 1V range dus blijkbaar is er ergens communicatie geweest.

Dat moet wel. Maar troost je, googelen op "keithley 2000 linux" levert wel wat bruikbaars op...

Prosper, yop la boum, c'est le roi du macadam (aldus Maurice Chevalier)

Probeer anders een de terminal van Bray++. Die werkt heerlijk als je RS-232 testjes moet doen.

En over die meerslagen potmeters, moet je eens je nagel er tegen laten schieten als je 'm net hebt afgesteld. Sommigen verlopen erg veel!

Leuk topic dit trouwens, erg leerzaam! :)

Kom eens langs bij RevSpace of één van de andere spaces!

En over die meerslagen potmeters, moet je eens je nagel er tegen laten schieten als je 'm net hebt afgesteld. Sommigen verlopen erg veel!

En vaak --zeker bij de goedkope uitvoeringen-- moet je bij het afregelen "naar de andere kant" eerst een halve slag terugdraaien alvorens er wat beweegt. En dan beweegt het meteen meer dan gewenst.
Meestal gebruik ik (als het precies moet zijn) een combinatie van vaste weerstanden en een multiturn, waarbij het regelbereik van die laatste zo klein mogelijk is.
Vergulde pinnetjes uit een afgedankte pers-connector, zoals deze hier zijn daarbij een handig hulpmiddel om weerstanden in te klemmen tijdens de afregel-periode. Als die afgelopen is, kan je ze daarop vast solderen.
En opnieuw afregelen omdat het soldeersel de afregeling scheeftrekt... >:)

Prosper, yop la boum, c'est le roi du macadam (aldus Maurice Chevalier)
fred101

Golden Member

Ik heb cutecom gevonden. Een rs232 terminal. Kan je gewoon alles instellen, opdrachtregel en resultaat venster. Ik kan met :read? enz nu inderdaad commando's sturen , de output kan naar een file maar ik kan niet doorlopend lezen. Tenminste, ik weet niet hoe. Ik kan bv wel mbv een hele rits commando's de buffer vullen en die dan in een keer leegtrekken maar ik wil bv om de de 10 sec of om de minuut een meting doen en loggen.

Dit is de Vref maar net na opstarten en nog niet afgeregeld. Ik zet inderdaad een multiturn over een weerstand maar als je niest verloopt zo'n kreng al. Die tip van Pros is handig voor mijn definitieve versie. Dan maak ik op de print wat pennen en dan aan de weerstand een huls en dan kan ik ze zo opsteken.

http://www.pa4tim.nl/wp-content/uploads/2011/06/cutecom.png

www.pa4tim.nl, www.schneiderelectronicsrepair.nl, Reparatie van meet- en calibratie apparatuur en maritieme en industriele PCBs

Die Windows terminal uit mijn vorige post kan macro's sturen met intervallen instelbaar in msec, kan die linux terminal dat ook niet toevallig?

Kom eens langs bij RevSpace of één van de andere spaces!
blackdog

Golden Member

Ha die Fred101 en pros.

Ik lees dat jullie nog steeds aan het stoeien zijn met Referentie spanningen.
Ik heb vanavond met onderdelen die ik nog over had een 10V Ref gebouwd.
Vooral omdat Fred klaagde dat de apparatuur die hij daar heeft nogal een hoge Ri heeft.

De 10V ref die ik hier gebouwd heb heeft een Ri die ik niet kan meten,
ik bedoel hiermee dat op een 6,5 digit meter hij niet instort, dat is dus minder dan 10uV.
Hoe goed hij echt is/word hangt geheel af van hoe goed je bent wat betreft sterbedrading.
De ruis zit volgens de "Audio Precision" hier rond de 1,5uV, mijn ruisvloer is echter rond de 1uV in 20Khz bandbreedte.
Het is lastig het laatste restje brom weg te krijgen, en de 50 Hz is echt dominant. De Audio Precision kan je instellen als ontvanger, hij heeft een doorlopend bandfilter van 10Hz tot 100Khz, lekker makkelijk om storing en het niveau er van te vinden.
Het is dus een soort Spectrum Analyser maar dan wel met de hand bediend :-)

Hieronder de link met het Schema...

www.bramcam.nl/10V-Ref-Fred.jpg

In dit schema zijn verschillende technieken samen gekomen voor een lage ruis en stabiele spanning.
R1 en 2, C1 en 2 is een bootstrap schakeling zodat je elco's kan gebruiken zonder last te hebben van de lekstroom van de elco's.
Door de lekstroom die door R2 gaat valt een spanning van enige milivolts, dit is nu ook de DC spanning over C1, door deze lage spanning is de lekstoom door R1 te verwaarlozen.

R1 is ook precies de helft van de waarde van R3 + R7, dit is voor opheffen van de fouten door de bias stromen die in of uit de ingangen van de opamp stromen.

De potmeter voor het ijken heeft een erg lage waarde, deze word nog lager gemaakt door de twee 1 Ohm weerstanden die parallel aan de loper staan. hierdoor is het bereik erg klein geworden.
Dit is alleen maar gunstig, nu is de 10V mooi in te stellen zonder dat je veel last hebt "backlash" van de instel potmeter.
Verder valt de temperatuur gevoeligheid erg gunstig uit door de grote verhouding tussen de instel weerstanden en R3 en 7.
R3 en 7 moeten nu natuurlijk wel heel goed aan elkaar gelijk zijn, hier kleiner dan 0,01%.

R10 + C6 + C4 zijn een Lowpass Filter, deze filterd de ruis zo veel mogelijk. Bij een waarde van C4 van 0,1 uF heb je de laagste ruis, alleen bij grote belasting variaties (van 1 naar 10mA hier getest)duurt het redelijk lang voor hij weer terug is op 10V.
Ik heb het dan wel over kleine variaties, binnen 0,1 seconde weer op 10.00000V.
bij 10nF gaat dit een stuk sneller natuurlijk maar dan iets meer ruis.

De BD139 of zoiets dient er voor om de uitgangselco snel vol te krijgen zonder de opamp te belasten.
Doordat de opamp nu vrijwel geen belasting ziet heeft hij zijn volle openloop versterking wat de stabiliteit ten goede komt.

R8 en R9 zijn voor de stabiliteit en wat stroombegrenzing bij kortsluiting.

Hoe stabiel is deze schakeling?

1e
Hang van de bouwer van de schakeling af...

2e
De LT1021, lange termijn drift ( deze heeft al 4 maanden continu aan gestaan )

3e
Drift R3 en R4 (hier VisHay metaalfilm)

4e
Offset en Bias drift opamp

5e
Temperatuur verschillen, bouw hem in een dikke Alu doos (Bimbox)
Dan weet je dat de verschillen langzaam zijn.
Kan je hem altijd kachelen, heb ik ook een schema voor die hem ruim binnen 0,01C houd :-)

Fred
Als je deze schakeling eens wilt proberen, dan schenk ik je de de LT1021 en de 2K54 0,02% weerstanden.
Ik zou verder toch adviseren om een LT1012AC te gebruiken en als je geen AC versie kan of wilt kopen dan maar de c versie.

De OP177 heeft namelijk een 10x zo hoge bias stroom.
Maar je kan het in ieder geval eens proberen met die opamp.

Succes en ik hoor het wel van je

Gegroet,
Bram

You have your way. I have my way. As for the right way, the correct way, and the only way, it does not exist.
rbeckers

Overleden

Bram, heb je toch geen last van lekstromen door de elco's?

blackdog

Golden Member

Ha die Rbeckers,

Wat betreft C1 en 2 heb ik het uitgelegd, door de zeer lage spanning over C1 loopt er ook een te verwaarlozen lekstroom.

C5 en 6 over de uitgang is niet van belang, de stoom die daar loopt word gecompenseerd door de opamp, de opamp weet niet of de stroom die door b.v. R11 ( een voorbelasting ) of door de uitgangscondensatoren loopt.
Wat ik was vergeten te vertellen, C4 moet wel een goede film condensator zijn, weinig lek dus. dit is meestal geen probleem...

Gegroet,
Bram

You have your way. I have my way. As for the right way, the correct way, and the only way, it does not exist.
rbeckers

Overleden

Bram, ik heb je uitleg mbt C1 en C2 gelezen.
Ik heb daar mijn twijfels over.
O.a. de lekstroom door C2.

[Bericht gewijzigd door rbeckers op vrijdag 24 juni 2011 23:37:02 (15%)

blackdog

Golden Member

Ha rbeckers,

Ik zou zeggen, probeer het eens, diverse "Analoge Goden" gebruiken deze schakeling.
Je vind het in application notes van Lineair en Burr-Brown.
Maar je hebt mijn zegen om de elco's weg te laten er er alleen een goede film condensator in te plaatsen ;-)

Gegroet,
Bram

You have your way. I have my way. As for the right way, the correct way, and the only way, it does not exist.
rbeckers

Overleden

O.a. in de AN42 van Lineair.
Maar een goede, low leakage, 100uF elco kan gemakkelijk een lekstroom hebben van, heel ong., 100nA tot 1uA (Vishay 013 RLC).

blackdog

Golden Member

Ha die rbeckers,

Heb je begrepen dat er maar een paar milivolt over de bovenste elco staat?
Bouw de schakeling eens op en meet de spanning over de 10K weerstand,
bij redelijk goede elco's kom je niet verder als een paar milivolt,
hiet trouwens met 2 Philips elco's van een jaar of 10 oud en 15V is de spanning over de 10K rond de 3mV.
Die 3mv is de spanning over de bovenste elco, door die lage spanning
is de lekstroom door die elco ook heel erg laag.
De lekstroom is afhankelijk van de spanning over de elco.

Als je het gaat meten hou er dan rekening mee dat de spanning erg laag zijn, het beste in een dichte doos en laat de schakeling zeker 15 minuten met rust. dit is geen schakeling om regelmatig aan en uit te schakelen, is meer bedoeld voor 24/7 gebruik.

Laat eens weten wat jij meet, ik zit na een minuut of 5 al aan onder de 100uV over de 1K weerstand.

Gegroet,
Bram

PS
Hou er rekening mee dat de ruis uit de voeding waarmee je misschien gaat testen roet in je meting kan gooien, dit werkt alleen goed bij een al stabiele spanningen, minimaal een 7805 gebruiken die goed ontkoppeld is.

You have your way. I have my way. As for the right way, the correct way, and the only way, it does not exist.
fred101

Golden Member

Hi Bram, ik ben altijd in voor experimenten. Ik heb nu de boel dicht geschroeft en hij staat nu een paar uur aan. De korte termijn drift is minder dan 5 uV. Waarschijnlijk zal dat met digitaal filter aan, een lagere samplingrate en low thermal EMF meetsnoer nog iets beter kunnen.

Ik heb de manier gevonden om de trimmer af te regelen. Ik zet hem wat te hoog en dan klop ik net zo lang op het kastje tot hij niet meer verder zakt ;-) Na een keer of twintig zat ik in de buurt van de 1.1V Helemaal precies doe ik pas als ik het lange termijn effect weet. Bij afregelen zo'n twee uur geleden stond hij rond 1,099.988 te wiebelen nu nog steeds. Ik kijk via de PC beneden af en toe, de deur van het lab is dicht dus geen storende invloeden.

Hij blijft dus best stabiel met willekeurige junkbox onderdelen en natuurlijk op zijn Fred's gebouwd (dus geen speciale PCB lauouts maar gewoon dead bug) De eerste proef met die LT084 was wel lachen. 4 smd Vrefjes met 4 enorme metaalfilm weerstanden (ongeveer 4cm lang)De voeding staat gewoon open en bloot en de draden van voeding naar schakeling zijn zo'n 15cm. Daar is dus zeker nog winst te halen. Op dit moment is de OP07 denk ik de beperkende factor.

Schema: http://www.pa4tim.nl/?p=2531
http://www.pa4tim.nl/wp-content/uploads/2011/06/Vref1.png

www.pa4tim.nl, www.schneiderelectronicsrepair.nl, Reparatie van meet- en calibratie apparatuur en maritieme en industriele PCBs

@Bram: tja, dat is wel wat anders dan enkele driepotige spanningsregelaars in serie zetten, en hopen dat er wat bruikbaars uitkomt.

Die truuk met de elco's kende ik niet - als ik een elco met lage lekstroom nodig had, nam ik een exemplaar voor een hogere spanning (63V bv.) die ik dan via een weerstand van 1k op 50V aansloot tot er over de weerstand geen spanning meer te meten was. Vervolgens herhalen met een weerstand van 10k, 100k en 1M.
Na een week heb je dan een elco die praktisch niet meer lekt op 50V, tenzij je een slecht exemplaar te pakken hebt. Op een lagere spanning lekt hij dan nog minder.
Maar jouw aanpak lijkt me heel wat eleganter - heb je tenminste geen grote knoeften van elco's meer nodig.

@Fred:

Ik kan bv wel mbv een hele rits commando's de buffer vullen en die dan in een keer leegtrekken maar ik wil bv om de de 10 sec of om de minuut een meting doen en loggen.

Misschien lukt het, door een named pipe als commando-bestand op te geven.

code:

mkfifo Commands

Als cutecom zo vriendelijk is, "Commands" als input-file te behandelen, kan je daar met een scriptje opdrachten heensturen:

code:


#!/bin/sh

echo ""SYST:REM" > Commands
# Meer init-commando's...

while true
do
    echo "READ?" > Commands
    sleep 60
done

Als cutecom eerst het volledig bestand wil lezen, alvorens het door te sturen, gaat het niet werken natuurlijk. Maar het is het proberen waard.

[Wat later...]
Nee, dat lukt niet. Cutecom blijft netjes wachten tot hij een EOF ziet, om dan gans de boel in één hap te verzenden. Maar je kan cutecom gebruiken om de baudrate e.d. goed te zetten, en de rest gewoon naar /dev/ttyUSB0 te zenden.
Misschien zijn vorige pogingen mislukt omwille van dat \r\n gedoe? Iets als

code:

echo -e "Je commando\r" > /dev/ttyUSB0

zal wellicht beter lukken.

[Bericht gewijzigd door pros op zaterdag 25 juni 2011 08:40:06 (12%)

Prosper, yop la boum, c'est le roi du macadam (aldus Maurice Chevalier)
rbeckers

Overleden

@Bram
Ik begrijp je verhaal. Deze truc is nog steeds afhankelijk van de uitgangsweerstand van de spanningsref.
Bij een uitgangsweerstand van bijv. 10 Ω en jouw 3mV over die 11k is dat 3µV.

Ik zal vanmiddag wat testen.

fred101

Golden Member

Volgens de datasheet is de 5V Ref het beste wanneer hij een klein beetje moet sourcen. Ze adviseren een capacitieve load van 1nF maar in kritische situaties een 10uF met een weerstand van een paar ohm in serie.
Die elco truc kan dus best goed uitvallen. Als die elco's te goed zijn heb je te weinig sourcing. Hij is het slechtste als hij niks sourced dus elco lekkage lijkt me zinning.
Maar de stabiliteit is wel afhankelijk van een vrij onbetrouwbaar onderdeel, een elco.

In jou schema gebruik je de trim niet, wat is je reden daarvoor, is het stabieler dat door de opamp te laten doen ?

Pro's: ik ga dat proberen. Ik ga ook uitzoeken hoe ik vanuit een C programma de RS232 kan aansturen want dan kan ik jouw software aanpassen. Nu ik weet dat het werkt en de instellingen moet het ook via de terminal kunnen.

www.pa4tim.nl, www.schneiderelectronicsrepair.nl, Reparatie van meet- en calibratie apparatuur en maritieme en industriele PCBs
flash2b

Special Member

Op 25 juni 2011 01:01:33 schreef fred101:
Schema: http://www.pa4tim.nl/?p=2531

Volgens mij kun je beter een 100n én een 10uF condensator over de Anode en de Cathode van elke TL431 zetten (VR1..VR4).

fred101

Golden Member

Daar ben ik nog niet uit. Ik heb al een paar keer artikelen gelezen over dit onderwerp (mbt netwerk analyse) waarbij bij metingen bleek dat twee C's parallel een slechter effect hadden dan maar een. Nu was dat wel bij RF toepassingen. Ik zal het proberen alleen het effect meten is lastig.
Ik heb een scoop en probe die qua belasting zou kunnen maar die begint pas vanaf zo'n 30MHz te meten. Ik heb al met de scoop gemeten met een 0,1mV/div plugin en met een DSO. Die DSO (Rigol) was onbruikbaar. Die gaf 20mV ruis op de voeding terwijl dat minder dan 5mV was.
Ik heb wel een actieve probe van Philips maar nog geen goede voeding daarvoor. De voeding gemaakt met twee spanningsregelaars geeft oscillaties in de probe. Ik moet dat nog aanpassen.

www.pa4tim.nl, www.schneiderelectronicsrepair.nl, Reparatie van meet- en calibratie apparatuur en maritieme en industriele PCBs

Ik ga ook uitzoeken hoe ik vanuit een C programma de RS232 kan aansturen...

Je kan /dev/ttyUSB0 als een gewoon bestand openen met fopen(), er naar schrijven met fprintf() en uitlezen met fgets().
Daarbij is het wel nuttig, eerst te forken, en de parent te laten schrijven, terwijl het child het uitlezen op zich neemt. Dan hoeft de "schrijver" niet te wachten op antwoord (dat er om een of andere reden misschien niet komt).

Initialiseren doe ik zo:

c code:


void init_tty(void)
{
    int                     tty;
    struct termios          tty_portset;

    tty = open("/dev/ttyUSB0", O_WRONLY | O_NOCTTY | O_NDELAY);
    if (tty == -1) {
	// Mislukt. Hier wat error-code...
    } else {
	tcgetattr(tty, &tty_portset);
	cfmakeraw(&tty_portset);
	cfsetospeed(&tty_portset, B9600);	// Stel in op 9600bd (of B4800, B19200, ...)
	tcsetattr(tty, TCSANOW, &tty_portset);
	tcflush(tty, TCIOFLUSH);
	close(tty);
    }
}
Prosper, yop la boum, c'est le roi du macadam (aldus Maurice Chevalier)
blackdog

Golden Member

Ha die Fred en anderen,

Fred, de rede dat ik niet de trimfunctie gebruik van de LT1021 is dat ik een stuk of 15 van deze referenties al een maand of 6 aan heb staan.
Als je de application notes en datasheet leest, kom je er achter dat het gebruik van de trim functie de temperatuurgevoeligheid wat slechter word, dus ik kies er voor, dit op een ander punt te doen omdat ik een geselecteerde van de LT1021 gebruik.
De LT1021 in de 7V versie is het meest stabiel. Die heb ik niet...

Wat betreft jouw schema.
Je zet 4x TL431 parr, dat is een leuk systeem, ik ga dat met 4 of 8x 1N829a doen die ik op een dikkefilm weerstand lijm en dan een klein beetje verwarm zodat hij rond de 45C word. als ik voor 8x de 1N829a kies stoken die al 8x 7,5mA dat is rond de 0,5 Watt, later meer hierover.

Maar nu wil ik het even over het optimaliseren van je schema hebben.
Je "mix" weerstanden hebben een te hoge waarde, zover ik het kan zien 47K, breng dit terug naar rond 1K.
R5, 6 en je potmeter zal je ook moeten aanpassen om weer de gewenste uitgansspanning te krijgen.

Slaan op een potmeter om je Ref op spanning te krijgen hahahahahha.
Zorg er voor dat je potmeter een zeer klein bereik krijgt, meestal een lage waarde van de pot met in verhouding een hoge waarde van de serieweerstand die je bij de potmeter gebruikt.
Zeg dat je een Referentie bouwt van 10V, gebruik dan een 20/25 slag instelpotmeter kies de weerstanden er omheen zo, dat voor een halve slag van die potmeter de uitgangsspanning 10uV veranderd.
Je kan de verhouding ook nog lager kiezen maar ik heb geen Agilent 3458A 8.5 digit meter, moet het met 2x 6,5 digit doen.

De weerstand aan de plusingang van bijde opamps moeten de zelfde waarde hebben als de parallel weerstand aan de andere ingang.
Dat is bij je eerste opamp dus 4x47k = 11K75 met par er aan zeg 19K, dan kom je uit voor R15 op een waarde van 7K2.

Trapje no2
Hier kies je voor 100K dit is veel te hoog gebruik 5 of 10K.
Zeg dat je voor R13 en R7 10K gaat gebruiken dan zal R16 5K worden.

Waarom al deze aanpassing?
Door de hoge weerstand waardes heb je veel last van ruis.
Plaats over R5, 15 , 7 en 16 een film condensator.

rbeckers
De Ri van de LT1021 is kleiner dan 0,1 Ohm.

Bij 15V loopt er hier 0,35uA door de onderste elco.
Bij 5V, zoals in mijn schakeling, loopt er rond de 30nA.
Door de bovenste 1K weerstand loopt ongeveer 3nA.
Dit is al vrij lastig te meten zonder korte snoeren en het geheel te bouwen in een dichte metalen doos....

Je kan de 2 elco's ook gewoon weg laten en een goede MKP condensator
van zeg 0,47uF gebruiken, het kantelpunt van het filter komt wel 100x hoger te liggen. De LT1021 heeft van 10H - 10KHz ongeveer 6uV TT ruis.
Het meeste word er door mijn opamp schakeling er al uit gehaald.
(en ook wat toegevoegd natuurlijk) Ieder voordeel heeft zijn nadeel!

"1e, Stabiliteit, Hang van de bouwer van de schakeling af..."
Ook al heb je de beste componenten.

Ben ondertussen een klein jaartje bezig met het bouwen van verschillende spanningsreferenties, daar doe je lekker veel ervaring
op wat betreft weerstand van bedrading, 1cm draad is niet "0" Ohm, ook niet bij benadering...
Bij het bouwen van precisie schakelingen moet je met heel veel zaken rekening houden.
Je bent met DC bezig maar er zijn ook veel overeenkomsten met het bouwen van HF schakelingen :-)

Ik hoor graag jullie ervaringen en opmerkingen.

Gegroet,
Bram

You have your way. I have my way. As for the right way, the correct way, and the only way, it does not exist.
rbeckers

Overleden

Bram, ik heb wat 100uF elcos gemeten. Lekstromen tussen de 30nA en 300nA bij 5V en bij 18,5 graden celsius.
Wat opvalt is de gevoeligheid. Even aanraken en de lekstroom stijgt snel.
Als de Ri van de LT1021 zo laag is, dan is het effect van de lekstroom veel kleiner. Maar ik gebruik toch liever een MKP.

Heb je ook ervaring met de REF102 vaan TI?

ik ga dat met 4 of 8x 1N829a doen die ik op een dikkefilm weerstand lijm en dan een klein beetje verwarm zodat hij rond de 45C word...

Kan je niet beter alles samen inblikken, thermisch isoleren, en daar een oventje van maken? Dan krijg je iets als dit hier. Zo hou je meteen alle componenten op een gelijkmatige temperatuur.

Prosper, yop la boum, c'est le roi du macadam (aldus Maurice Chevalier)