Elektronische sluiter camera 555 timer

Sens

Golden Member

Hallo,

Ik ben ook uren bezig met LT Spice.
Wat een mooi programma.
Begin het door te krijgen.
De schakeling staat er al op en de simulatie lukt al een beetje.
.
Toch werkt het R / C stuk wel.

Heb jij een logische file van de schakeling in LT Spice?

Ik heb die van mij toegevoegd!

Groeten,

Thevel

Golden Member

De NE555 en aanverwante monostabs hebben vaak de onhebbelijkheid op allerlei stoorsignalen te triggeren

De triggeringang is tijdelijk aan de plus gelegd, je mag daar dus helemaal geen last van hebben.
Maar goed, morgen maar eens testen.

Thevel

Golden Member

Mijn schakeling is ongeveer hetzelfde.
Alleen heb ik de voeding geprogrammeerd zodat deze pulsen van een aantal 1ms geeft.
Zelfs met die korte tijd kun je in de simulatie zien dat het goed werkt.
Simuleren is leuk maar de praktijk kan misschien toch net anders zijn, vandaar dat ik het ook nog op een breadboard wil testen.

Sens

Golden Member

OK bedankt.

Ik heb de schakelaar doorverbonden omdat deze tijdens de gehele cyclus gesloten blijft.

Ik zie wel 2 verschillen.
De waarde van C2 is bij mij 0,035 nF en bij jou 3,3 nF
De transistor is bij mij BC 547 en bij jou BC 847B

Ik weet niet of het veel uitmaakt.

[Bericht gewijzigd door Henry S. op 24 november 2015 01:38:30 (43%)]

Thevel

Golden Member

0,035nF of 3,5nF maakt in de simulatie voor de werking niets uit.
BC547 of BC547B bepaald de versterking van de transistor, maar dat maakt in deze schakeling ook niet uit.

Thevel

Golden Member

Vandaag de schakeling gebouwd op een breadboard, de schakeling werkt hetzelfde als in de simulator, geen problemen dus.

Als er op Pen 4 van de 555 met geopende schakelaar spanning wordt gezet dan blijft de uitgang ten alle tijde laag, er wordt geen enkele puls gegeven, ook dit is zoals het hoort.

Wel heb ik een ander probleempje gevonden waar nog niet eerder aan gedacht is: contactdender!
Ik weet niet hoe je getest hebt, met een losse schakelaar of met de ontspanknop van de camera maar een schakelaar sluit meestal niet in één keer en worden in zeer korte tijd meerdere pulsen gegeven.
Zeker als de sluitertijd heel kort is b.v 1ms dan worden er op de uitgang van de 555 meerdere pulsen gegeven.
Als op de uitgang een LED zit dan kun je normaal een puls van 1ms nauwelijks zien maar door de contactdender zie je de LED nregelmatig flikkeren!

Ik heb in het schema C5 en R6 toegevoegd om de contactdender weg te filteren.
In de simulator werkt dit perfect, heb het ook getest op het breadboard en werkt ook probleemloos.

Sens

Golden Member

Bedankt Thevel voor alle energie die je in mijn probleem stopt!

Ik ga het schema bouwen en simuleren.

Ik heb 1 vraag over de voeding en het inschakelen.

Je schrijft "Als er op Pen 4 van de 555 met geopende schakelaar spanning wordt gezet dan blijft de uitgang ten alle tijde laag, er wordt geen enkele puls gegeven, ook dit is zoals het hoort."

De ontspanknop van mijn fototoestel sluit en geeft de schakeling voeding. Dat blijft zo tot het relais is afgevallen.

De schakelaar geeft dus geen korte puls, maar een maak-contact tot einde cyclus.
Zo werkt het ook bij jou? Dat is toch de bedoeling?

mvg,

Halvor

Thevel

Golden Member

Op 21 november 2015 11:56:48 schreef Sens:
LED-je blijft wel uit bij testje 1. Knippert af en toe zwak bij loshalen van de voeding.

Om die reden heb ik voor de test tijdelijk de NE555 permanent met de voeding verbonden om te kijken of bij een geopende ontspanknop de uitgang reageerde bij het in en uitschakelen van de voeding.
Dat bleek dus niet te gebeuren (zoals het hoort)

De schakelaar geeft dus geen korte puls, maar een maak-contact tot einde cyclus.
Zo werkt het ook bij jou? Dat is toch de bedoeling?

Ja, dat is inderdaad de bedoeling!

Sens

Golden Member

Prima, helemaal duidelijk.

Ik ga het aanpassen!

Groeten.

Sens

Golden Member

Zou je misschien het .asc bestandje van de laatste versie kunnen sturen?
Dan weet ik zeker dat ik de goede simulatie te pakken heb.
Alvast bedankt!

Ik laat snel wat van me horen!

Groet, Halvor

Thevel

Golden Member

De voeding linksonder genereert een reeks zeer korte pulsen wat een beetje op contactdender lijkt.
Op de uitgang van de NE555 zie je dat er alleen op de eerste puls getriggert word, het filter werkt dus prima.
Pas als de tijd tussen de pulsen langer zijn dan 30ms worden deze wel doorgelaten.
Deze tijd kun je in de voeding instellen bij Tperiod[s ] (deze tijd staat nu op 0.02)

Sens

Golden Member

Ik zie het in de simulatie met de pulsen goed werken.

Maar als ik de voeding verander in een gewoon sluiten en dichthouden van de schakelaar, dus gewoon 6V op het circuit zetten, dan komt er geen uitgangspuls op pen 3. Dat zou de situatie zijn bij een perfecte sluiterknop.
Klopt dat?

Ik zet de voeding dan op DC Value en vul daar onder 6 Volt in.
Dat zou dan toch meten werken? Of doe ik iets fout?

Thevel

Golden Member

Maar als ik de voeding verander in een gewoon sluiten en dichthouden van de schakelaar, dus gewoon 6V op het circuit zetten, dan komt er geen uitgangspuls op pen 3.

Ik snap wat je bedoeld, je zet er 6V op en daarna start start je de simulatie.
Helaas gaat dit niet goed in Ltspice, ik weet niet waarom maar ik heb bij andere simulaties ook gehad dat dit niet goed gaat.
Je moet de voeding programmeren dat deze iets later start, een paar ms is al genoeg!

Sens

Golden Member

OK, heel helder.
Als ik het bij de puls ook zo instel dat er een constante spanning is met en korte vertraging, dan gaat het wel goed.

Wel fijn dat ik nu weet waarom dat is!

Thevel

Golden Member

Zoals ik al zei, het is iets in Ltspice, ik heb de eerste keer ook het apezuur zitten zoeken....

Sens

Golden Member

De simulatie in TLspice lijkt nu goed te gaan, maar de schakeling nog niet echt.

Af en toe gaat de LED even aan. Ik heb het idee eerder als ik het contact verbreek.
Het is alleen verre van reproduceerbaar...

Op het moment dat ik pootje 2 aan de massa leg, dan lijkt het dat de timer gaat lopen. Dat is wel reproduceerbaar...

Het triggeren op pootje2 lijkt mis te gaan...
Transistortje vervangen? Of iets anders testen?

Gr. H.

Sens

Golden Member

Na verder proberen heb ik ontdekt dat de schakeling goed werkt als ik eerst de condensator van de R/C combinatie kortsluit of wacht dat de spanning hierover is weggelopen.

Dan krijg ik een reproduceerbaar resultaat, tenminste met de LED!!!
Geeft hoop!

Hoe zou ik de C na de cyclus kunnen kortsluiten?

Daarnaast werkt de schakeling ook alleen maar als ik een voltmeter op aansluit tussen pen 2 en de massa.

Een voltmeter heeft een hoge interne weerstand volgens mij; die blijkt nodig te zijn, naast het kortsluiten van de C voordat de cyclus goed loopt.

Du met deze twee ingrepen lijkt het goed, reproduceerbaar te werken!

[Bericht gewijzigd door Henry S. op 4 december 2015 00:57:12 (35%)]

Thevel

Golden Member

Vreemd allemaal, bij mij op het breadboard werkt het zonder problemen.

C2 moet telkens snel ontladen worden, dat gebeurt via R3 en R6, de weerstand van de voltmeter (10MΩ) naar massa mag helemaal geen invloed hebben, ook in de simulatie is er zelfs met 1MΩ geen verschil te zien.
Zijn de condensatoren wel helemaal lekker?
Bij mijn test op het breadboard heb ik voor C2 een ceramisch 470pF en voor C5 een 220nF MKT gebruikt.

Enne.... we gaan door tot het werkt!

Sens

Golden Member

Ja vreemd.
Ik ben ook eens even terug gegaan naar een eenvoudige basis circuit.
Dat werkt nu wel. Reproduceerbaar en zonder fouten.
Ik denk dat ik stap voor stap ga uitbreiden naar het complexere circuit.
Dan moet ik uiteindelijk tot een oplossing komen.

Het gaat lukken; dat weet ik zeker!

Sens

Golden Member

Welnu, de hele avond weer getest en het ziet er goed uit!!

Bijgaand het schema en bovendien 2 filmpjes. Een filmpje met een sluitertijd van 4 sec en 1/15 sec. Op het printplaatje zie je de LED aangaan als je goed kijkt.

Ik heb verder het volgende ontdekt.
Pen 6 wordt bij het spannen van de camera mechanisch aan de GND gelegd.
Bij het indrukken van de ontspanknop wordt eerst het circuit onder spanning gezet en pen 6/7 bliven aan de GND liggen. De LED gaat dan aan, dus pen 3 geeft spanning, maar de timer gaat nog niet lopen.

Dan wordt de sluiter mechanisch geopend en wordt op hetzelfde moment pen 6 losgezet van de GND en dan pas gaat de timer lopen. Ik kan me voorstellen dat dit een soort mechanische trigger is. In ons schema zat een elektronische trigger, maar de camera lost het zelf eigenlijk anders op. Aan het eind van de cyclus valt de sluiter af en is alles spanningsvrij.

Ik heb het een beetje "Peppie en Kokkie" uitgelegd, maar hopelijk kun je me volgen.
Ik heb de sluitertijden met een stopwatch vergeleken voor de 1 en 4 seconden en het zit behoorlijk in de buurt!
Ik begin werkelijk blij te worden!

Zal ik verder nog iets aan het schema veranderen?
Bijvoorbeeld voor contactdender of een extra diode? Aan de andere kant kan ik het ook eerst eens met een filmpje testen... Weer een nieuw spannend moment.

Gr. H.

Thevel

Golden Member

Hoe heb je het nu precies gebouwd, volgens de laatste simulatie?

Sens

Golden Member

Ik heb de eenvoudige versie nu gebruikt, volgens de simulatie in de laatste bijlage. (Bronica 4)

Op het printplaatje zit ook de eerdere schakeling, maar deze is in het filmpje niet aangesloten.

Thevel

Golden Member

Op 28 november 2015 00:20:45 schreef Sens:
Pen 6 wordt bij het spannen van de camera mechanisch aan de GND gelegd.
Bij het indrukken van de ontspanknop wordt eerst het circuit onder spanning gezet en pen 6/7 bliven aan de GND liggen. De LED gaat dan aan, dus pen 3 geeft spanning, maar de timer gaat nog niet lopen.

Dat begrijp ik niet, of bedoel je dat pen 6/7 elektronisch aan GND ligt.

Sens

Golden Member

Nee, ik druk me misschien niet helemaal duidelijk uit.

1/ Bij het spanner van de sluiter en het transporteren van de film wordt pen 6/7 mechanisch aan de massa gelegd. Hierdoor wordt de C ook mooi ontladen denk ik.

2/Bij het indrukken van de ontspanknop wordt eerst het circuit onder spanning gezet met pen 6/7 nog aan de GND. De LED gaat aan, maar verder gebeurt er nog niets. (Circuit Bronica 4-1)

3/ Bij verder induwen van de ontspanknop klapt de spiegel, gaat de sluiter open en tegelijkertijd wordt pen 6/7 los van de massa getrokken. (Circuit Bronica 4-2)

3/ De timer gaat lopen en het circuit valt af na de ingestelde tijd.

4/ Aan het einde van de cyclus ligt pen 6/7 niet aan de GND, dat gebeurt pas weer bij 1/

Het is eigenlijk een interessante combinatie van mechanica en electronica uit de jaren 70...

Is het zo duidelijker?

Verder heb ik de sluitertijden gemeten door de opening te filmen en met een Video-programma exact te bepalen hoe lang de sluiter opent bij een ingestelde waarde.

Ik heb de resultaten in een grafiekje toegevoegd; ziet er goed uit!